Compass Solution Getting Started Guide
## Content

Chapter 1 Software introduction .................................................................................................................. 2
  1.1 Function introduction .......................................................................................................................... 2
  1.2 Compass Solution user interface introduction ................................................................................... 2
Chapter 2 Compass Solution workflow ......................................................................................................... 4
Chapter 3 Project management..................................................................................................................... 5
  3.1 Create a new project ............................................................................................................................ 5
  3.2 coordinate system management ........................................................................................................ 6
  3.2 Import raw observation files ............................................................................................................. 8
  3.3 Key in the local grid coordinates ....................................................................................................... 9
Chapter 4 Data processing .......................................................................................................................... 11
  4.1 static baseline processing. ................................................................................................................ 11
    4.1.1 Process baseline automatically .................................................................................................. 13
    4.1.2 Process baseline manually ......................................................................................................... 13
  4.2 Network Adjustment ......................................................................................................................... 15
  4.3 PPK(Post-Processing Kinematic) ....................................................................................................... 16
Chapter 5 Export the report ........................................................................................................................ 18
  5.1 static network reports ....................................................................................................................... 18
  5.2 PPK Report ........................................................................................................................................ 19
Chapter 1 Software introduction

1.1 Function introduction

Compass Solution has ComNav’s own intellectual property, this software is packaged with ComNav OEM board as the post processing solution to maximize the positioning accuracy, there are 4 main functions of software:
1) Local coordinate system management.
2) Static baseline and kinematic route (dongle to activate the kinematic function) processing
3) Network adjustment
4) Export the processing report

1.2 Compass Solution user interface introduction

The below is the UI of Compass Solution and the brief introduction.
1. Main menu; you can find all the functions in those menu
2. Shortcut menu; in this menu, you can be easy to access the frequently used menu, such as import observation files, baseline processing, network adjustment
3. Left toolbar; according to the workflow of post processing, enter each menu and then you will see more detailed information of each workflow, and also the right main window will change according to each selection.
4. Main window; show the detailed information of each selection, also you can click the main window toolbar (top of the main window) to show the information you want to see.
5. Float window; show the information of observations data and data processing information, go to the Main menu -> View, activate this float window.
Chapter 2 Compass Solution workflow

The below flow diagram shows the whole workflow of Compass Solution, the most important step is showed in blue colour.

In the following chapter, we will follow the workflow to explain how to use compass Solution.
Chapter 3 Project management

Prerequisites:
Install Compass Solution software in PC, Download the GNSS data from receiver to PC.

3.1 Create a new project

Run the main programme Compass Solution, Select File->New Project, and firstly select the raw data file in the left file path, then key in the Project name.

Tips; we suggest you select the project path as same as the Raw data path, it will be easier for the project management.

In the coordinate System menu, you can select the existed coordinate system; if you are the first time to start the project, select unknown and click Ok to start the project.
3.2 coordinate system management

Go to the Main menu, **Tools-> Datum Manager.**
Click Add to add the local coordinate system to the data base

Firstly, tick the “use default ellipsoid”, and select the ellipsoid in the list (CLARKE 1880), at last input the coordinate system (BJ54).
Datum Convert; if you have the 7 parameters, please key in here. Those parameters are used to convert WGS84 to local grid coordinates from coordinate system A to B. Select Project module; In the Projection Module list, select the right module such as UTM, then go down to select the right Zone and Hemisphere according to the Project location.

In the Geoid Modules, select the right module, After that click OK.
This will go back to start menu, select the coordinate system you built already, this coordinate system will activate in current project.

3.2 Import raw observation files

In the main menu, File->Import, 4 format of data format. If you import Dynamic file, tick the Import Dynamic files
Attention, right now the Dynamic raw data can only support ComNav format.

After importing the raw data, go to the left Toolbar, Observation-> select the observation file, in the right main window, select the observations files and right click the Properties, edit the station name and antenna information.

3.3 Key in the local grid coordinates

Coordinate covert; if you fix the receiver on known points, in this step please key in the known value and use this value in adjustment.
In the left toolbar, click station-> then in the Station list, select the station in the main window, right click select Properties-> Known Point, key in the control points and tick Constraint
Chapter 4 Data processing

This chapter will introduce the static baseline and dynamic route processing.

4.1 static baseline processing.

After importing observation files, the baseline will be automatically formed according to common observation time span.

Click **Static Baseline** in the left Toolbar, in the static Baseline list, you will see the baseline information, in the right main window, show the detailed information of baseline processing information(right now show unprocessed information).
Before processing baseline, go to the main menu -> Processor -> Baseline setting, set the process parameters, we suggest you use default setting to process. Compass Solutions can process GPS/Glonass/Beidou raw data, please configure those according to your needs.
4.1.1 Process baseline automatically

Firstly, use the system default method to process baseline. After configuring those parameters, go to the main menu -> Processor -> Process all, the software will auto process all the baseline, you will see Baseline Quality Value (Solution type, Radio and RMS) and baseline information (dx, dy, dz, ds).

Quality check by 3 value, firstly check Solution (fix), then check Radio (≤3) and RMS value;

Loop’s Errors check, go to main menu -> Adjust -> Search loop’s Errors, you will get the PPM value of loop, also the baseline process information, if you want to get better result process the baseline of RMS and PPM bigger one.

<table>
<thead>
<tr>
<th>Baseline</th>
<th>Type</th>
<th>rms</th>
<th>dx</th>
<th>dy</th>
<th>dz</th>
<th>distance</th>
</tr>
</thead>
<tbody>
<tr>
<td>A30-&gt;A13.240K</td>
<td>37.6</td>
<td>0.0153</td>
<td>-7251.5486</td>
<td>-5935.4538</td>
<td>7379.1031</td>
<td>11927.5199</td>
</tr>
<tr>
<td>A30-&gt;A12.240K</td>
<td>17.4</td>
<td>0.0115</td>
<td>5906.5317</td>
<td>-1578.6307</td>
<td>4654.2335</td>
<td>7683.8195</td>
</tr>
<tr>
<td>A13-&gt;A12.240K</td>
<td>11.0</td>
<td>0.0178</td>
<td>13158.0878</td>
<td>4356.8137</td>
<td>-2724.8583</td>
<td>14125.9319</td>
</tr>
</tbody>
</table>

Simultaneous Loop (3 baselines) Relative error = 0.49ppm EX = -0.0075 EY = 0.0094 EZ = -0.0113 33737.2713

4.1.2 Process baseline manually

This step introduces some basic skills in baseline processing.

Change the elevation mask, go to the Main menu -> Processor -> Baseline setting, the default set is 20, if you have enough observation data, set to bigger value to prevent the bad GNSS signal.

Reverse Start and End, in the right main window, select the baseline and right click, select Reverse start and End.
Observation data edit, sometimes you need to edit the raw observation files, such as delete the bad observation data, or disable constellation system.

In the right main menu, select the baseline-> in the down log window-> output, Time Line and Quality.

In the Time Line window, edit the data according to the Quality chat.
For example, in the below, Quality (cycleslip), in the Time Line, select the cycle slip data(select the data means delete the data); after data edit, select the baseline right click mouse->Process this baseline alone.
4.2 Network Adjustment

After baseline process, go to the network adjust.
Go to the main menu-> Adjustment-> Adjustment setup.

3D; WGS84 coordinate as control points
2D; Horizontal adjustment, used as local gird coordinates as control points
H; Height adjustment.

The most frequently used method; 2D &H, local grid control points as adjustment.
Tips; if you are using 2D&H, please key in control points----see chapter 3.3.
After setting up adjustment, go to the main menu->Adjustment->Run Adjustment, click OK to continue.
The popup window gives you attention, 3D is used for WGS84 adjustment and 2D&H is used for local grid coordinates.

4.3 PPK (Post-Processing Kinematic)

PPK Post Processing mode, you need to use dongle to activate this function.
How to import the PPK observation files?
Base station; import observation file as same as static, also go to station-> key in the known coordinates.
Rover; when importing data, select “Import Dynamic Files” option and import the observation file.

Go to the left toolbar, in the Dynamic baseline-> the current Dynamic baseline, select the baseline in the right main window, right click the baseline->Process this baseline alone. Before process this baseline, the baseline information, such as Epoch Num, Fixed Epoch and Fixed Percent is unknown.

After post processing this baseline, you will see the baseline information; fixed epoch and fixed percentage.
Chapter 5 Export the report

This chapter will introduce how to export the processing report

5.1 static network reports

Go to the main menu, Report->Report(network adjustment report), this report is in web format; this report will store in the path of the current project path, Report folder.

In the network adjustment report, if the X square check fails, copy the Reference factor, and go to main menu, Adjustment->Adjustment Setup->Free adjustment, and past this value here, and do adjustment again.

Tips, the X square check is only for triangle network adjust; if only single baseline, the check will fail, but it does not matter, please only pay attention to the baseline processing accuracy(fix, Ratio and RMS)
Also you can check the detailed report and brief report.

5.2 PPK Report

After processing the PPK dynamic route, select the route and right click, go to the filter; Most frequently used format is Projection and Fix carrier phase.

Export format
Latitude/longitude; the report will in WGS84 format
Projection; the report will be in local grid format, this is most frequently used format.
Relative 2D; Horizontal distance relative to base station
Relative distance; 3D distance relative to base station
Solve style; the output report data quality filter,
There are 5 types of solutions, Fixed carrier phase= RTK fix.
After setting up the filter, click **ok** to exit this page.

The double click the dynamic routine, you will see the following window; right click this window, in the pop up window, click Report, save the report in **.csv** format.

After exporting report, go to the main menu->File->Save, save the project and exit software.